Salesforce Service Degradation

Incident Report for Specright

Resolved

This service disruption incident has been resolved.

https://status.salesforce.com/incidents/20004038
Posted May 21, 2026 - 20:20 PDT

Update

The Salesforce Service Disruption continues to cause intermittent disruptions for some customers.
Customers on affected instances may be unable to log in to Specright or complete outbound connection requests. They are actively investigating the cause and working on remediation. We will continue to monitor and provide updates.

https://status.salesforce.com/generalmessages/20000254
Posted May 21, 2026 - 19:39 PDT

Identified

Salesforce is aware of an issue with their network infrastructure that is causing intermittent disruptions for some customers. Customers on affected instances may be unable to log in to Specright or complete outbound connection requests. They are actively investigating the cause and working on remediation. We will continue to monitor and provide updates.

https://status.salesforce.com/generalmessages/20000254
Posted May 21, 2026 - 17:01 PDT

Update

Salesforce services are still in a degraded state. We will continue to monitor
Posted May 21, 2026 - 16:27 PDT

Monitoring

Salesforce servics are still encountering intermittent issues and we continue to monitor.
Posted May 21, 2026 - 15:13 PDT

Investigating

Currently, Salesforce is experiencing performance degradation on multiple services. We continue to monitor and will provide an updates.
Posted May 21, 2026 - 15:07 PDT
This incident affected: Specright Core Platform and Specright API Services.