Specright API Partial Outage

Incident Report for Specright

Resolved

This incident is resolved. The fix has been deployed and validated, and Specright API requests are returning normally. Any operation that failed during this window should now succeed on retry.

We apologize for the disruption. If you continue to see unexpected errors, please contact Specright Support.
Posted Aug 14, 2026 - 12:24 PDT

Monitoring

Validation for the fix is complete, and we are currently deploying the changes to resolve the 500 Internal Server Error responses affecting the Specright API. We are monitoring performance closely during rollout and will provide an update once deployment is complete and system stability is confirmed.
Posted Aug 14, 2026 - 11:09 PDT

Investigating

We are responding to an issue where a subset of users are receiving 500 Internal Server Error responses when making Specright API requests.

The root cause has been identified and a fix is currently undergoing internal validation. We will begin deployment as soon as testing is complete and will provide an update within the next 30–45 minutes.
Posted Aug 14, 2026 - 10:00 PDT
This incident affected: Specright API Services.